doi.org proxy and website outage
Incident Report for International DOI Foundation
Resolved
The DOI Proxy service and the DOI website have not been available to users from multiple geographical regions, roughly between 17:20 to 17:40 EDT. The issue seems to be resolved now.

Post-mortem:

The DNS resolution of doi.org, which is provided by Cloudflare, has been determined to be the cause. This was a Cloudflare issue that apparently affected a large number of sites (including for example Discord, Patreon, npmjs, DigitalOcean, Coinbase, Zendesk, Medium, GitLab, Fiverr, Upwork, Udemy according to a post on ycombinator). It seems like this was a Cloudflare issue, although some commentators have suggested something more widespread. We anticipate a thorough post-mortem from Cloudflare.

We determined the outage time based on both Nagios service that CNRI internally runs as well as the externally-run Pingdom service that we use to monitor the DOI services.
Posted Jul 17, 2020 - 22:20 UTC
Monitoring
We can confirm the issue has been caused by Cloudflare infrastructure. Things seem to have been resolved. We will monitor for a few more minutes before confirming resolution on the issue.
Posted Jul 17, 2020 - 21:49 UTC
Investigating
We noticed doi.org website and proxy services are currently not available for users from multiple geographical regions, possibly due to issues on the Cloudflare side. We are currently investigating.
Posted Jul 17, 2020 - 21:36 UTC
This incident affected: DOI Resolution Service and DOI Website.