Unusual spikes in traffic; potential impact on a small number of regular users

Incident Report for The DOI Foundation

Resolved

The traffic spikes have stopped. We will continue considering ways to prevent this kind of traffic from impacting the use of the system by other users in the future.
Posted Oct 12, 2025 - 21:56 UTC

Investigating

Overnight there was an unusual series of traffic spikes on the doi.org resolution servers. The spikes were large (100x normal traffic) but lasted for only seconds each time and happened roughly once an hour, so scaling in new resolution servers in response to traffic was not helpful.

Our "load shedding" infrastructure successfully kicked in and prevented any instability, at the cost of a small number of "friendly" requests potentially receiving either a 429 or 503 response. I estimate that up to 2000-3000 friendly requests might have gotten such responses, many of which are normally friendly bots, but some of which might have been ordinary users. If it was a human clicking a link, they almost certainly would have succeeded on trying a second time.

If there are any user complaints about doi.org resolution service early today (2025-10-12) I would be interested to know about it.

We are monitoring the situation to see whether these spikes resume, and considering ways to prevent this kind of traffic from impacting the use of the system by other users in the future.
Posted Oct 12, 2025 - 17:20 UTC
This incident affected: DOI Resolution Service.