Cloudflare network problems affecting doi.org links

Incident Report for The DOI Foundation

Postmortem

DOI resolutions start at Cloudflare, which provides a number of functions, notably including DDoS protection.

The Cloudflare outage on Tuesday is discussed at length at https://blog.cloudflare.com/18-november-2025-outage/ . DOI resolutions began to be partially impacted as early as 11:30 UTC, although some DOI resolutions continued to succeed for most of the outage. Our internal monitoring alerted us to the problem by 11:50 UTC.

Once it was clear that the Cloudflare outage was not going to be resolved quickly, we decided to bypass Cloudflare. This required access to Cloudflare functionality which was itself affected by the outage, but by 13:10 UTC we were able to finalize the bypass.

The bypass allowed DOI resolutions to resume within less than 2 hours of the initial issues, instead of the full 3 hour outage experienced by Cloudflare generally. The fact that many of the resources that DOIs point to were also offline, however, meant that the restart of successful resolution may not have been noticeable to all users, as DOI resolution may have succeeded in redirecting them to a document they were still unable to access. Additionally, we found that the bypass did not work for IPv6 traffic; we have resolved that issue should we decide to bypass Cloudflare again in the future.

We will continue to monitor DOI use of network services such as Cloudflare and AWS, as we have done for some years now, configuring them to optimize the DOI system. Cloudflare, which is on the whole quite reliable, will continue to be our DDoS mitigation solution for the immediate future, but we will continue to monitor that specific issue in combination with other alternatives.

Posted Nov 20, 2025 - 17:37 UTC

Resolved

Cloudflare reports that things have returned to normal. We have restored use of Cloudflare for DOI resolution at doi.org.

IPv6 access to doi.org should resume for any impacted IPv6 users as soon as DNS propagation and cache expiration is complete.
Posted Nov 18, 2025 - 17:23 UTC

Update

Cloudflare reports that their incident is resolved. We will continue to bypass Cloudflare for the moment while they monitor their fix. We note though, as an unfortunate limitation of bypass, that IPv6 access to doi.org is currently not working.
Posted Nov 18, 2025 - 14:47 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 13:23 UTC

Update

We have bypassed Cloudflare as a presumably temporary measure. Users may not see the effect of this immediately depending on DNS propagation and caching, but if Cloudflare's incident continues, this should help to allow more DOI resolution.
Posted Nov 18, 2025 - 13:22 UTC

Investigating

Cloudflare is experiencing a global network issue which is affecting many internet services, including DOI resolutions on doi.org. Services should return to normal once the issue at Cloudflare is resolved. For more information and updates on the Cloudflare outage, see https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:55 UTC
This incident affected: DOI Resolution Service and DOI Website.